Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 48
Number of unique artifacts (NOA): 55
Number of version-conflicting artifacts (NOC): 5
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): error 87 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.

Dependencies used in this project

com.squareup.okio:okio

error
1.13.0
    org.kohsuke:github-api:jar:1.93
    \- com.squareup.okhttp3:okhttp-urlconnection:jar:3.9.0:compile
       \- com.squareup.okhttp3:okhttp:jar:3.9.0:compile
          \- (com.squareup.okio:okio:jar:1.13.0:compile - omitted for conflict with 1.6.0)

1.6.0
    org.kohsuke:github-api:jar:1.93
    \- com.squareup.okhttp:okhttp-urlconnection:jar:2.7.5:compile
       \- com.squareup.okhttp:okhttp:jar:2.7.5:compile
          \- com.squareup.okio:okio:jar:1.6.0:compile

commons-codec:commons-codec

error
1.6
    org.kohsuke:github-api:jar:1.93
    \- org.eclipse.jgit:org.eclipse.jgit:jar:4.9.0.201710071750-r:test
       \- org.apache.httpcomponents:httpclient:jar:4.3.6:test
          \- (commons-codec:commons-codec:jar:1.6:test - omitted for conflict with 1.7)

1.7
    org.kohsuke:github-api:jar:1.93
    \- commons-codec:commons-codec:jar:1.7:compile

commons-io:commons-io

error
1.3.1
    org.kohsuke:github-api:jar:1.93
    \- org.kohsuke.stapler:stapler-jetty:jar:1.1:test
       \- org.kohsuke.stapler:stapler:jar:1.177:test
          \- (commons-io:commons-io:jar:1.3.1:test - omitted for conflict with 1.4)

1.4
    org.kohsuke:github-api:jar:1.93
    \- commons-io:commons-io:jar:1.4:compile

commons-logging:commons-logging

error
1.0.3
    org.kohsuke:github-api:jar:1.93
    \- org.kohsuke.stapler:stapler-jetty:jar:1.1:test
       \- org.kohsuke.stapler:stapler:jar:1.177:test
          \- commons-beanutils:commons-beanutils:jar:1.7.0:test
             \- (commons-logging:commons-logging:jar:1.0.3:test - omitted for conflict with 1.0.4)

1.0.4
    org.kohsuke:github-api:jar:1.93
    \- org.kohsuke.stapler:stapler-jetty:jar:1.1:test
       \- org.kohsuke.stapler:stapler:jar:1.177:test
          \- commons-discovery:commons-discovery:jar:0.4:test
             \- (commons-logging:commons-logging:jar:1.0.4:test - omitted for conflict with 1.1.3)

1.1
    org.kohsuke:github-api:jar:1.93
    \- org.kohsuke.stapler:stapler-jetty:jar:1.1:test
       \- org.kohsuke.stapler:stapler:jar:1.177:test
          \- org.kohsuke.stapler:json-lib:jar:2.1-rev6:test
             \- (commons-logging:commons-logging:jar:1.1:test - omitted for conflict with 1.0.4)

1.1.3
    org.kohsuke:github-api:jar:1.93
    \- org.eclipse.jgit:org.eclipse.jgit:jar:4.9.0.201710071750-r:test
       \- org.apache.httpcomponents:httpclient:jar:4.3.6:test
          \- commons-logging:commons-logging:jar:1.1.3:test

junit:junit

error
4.12
    org.kohsuke:github-api:jar:1.93
    \- junit:junit:jar:4.12:test

4.5
    org.kohsuke:github-api:jar:1.93
    \- org.kohsuke.stapler:stapler-jetty:jar:1.1:test
       \- org.kohsuke.stapler:stapler:jar:1.177:test
          \- (junit:junit:jar:4.5:test - omitted for conflict with 4.12)